составить программу в паскале для поиска простых чисел в числовом промежутке от 1 до 100

program abc;
var
  i, j:integer;
  pr:boolean;
begin
  writeln(Простые числа в диапазоне от 1 до 100: );
  for i := 2 to 100 do
  begin
    pr := true;
    for j := 2 to i div 2 do
      if i mod j = 0 then
      begin
        pr := false;
        break;
      end;
    if pr then
      write(i, );
  end;
  writeln;
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку