Заданы две клетки шахматной доски. Если они покрашены в один цвет, то выведите слово YES, а если в разные цвета — то NO. Программа получает на вход четыре числа от 1 до 8 каждое, задающие номер столбца и номер строки сначала для первой клетки, потом для второй клетки.

Клетка будет черной, если номер столбца и номер строки будут одновременно четными или нечетными. Белыми, если один из них четный, а второй нечетный.
var a,b,c,d,t,k:integer;
begin
k:=0;
t:=0;
read(a);
read(b);
read(c);
read(d);
if (a mod 2=0) and (b mod 2=0) or (a mod 2=1) and (b mod 2=1) then
t:=1;
if (c mod 2=0) and (d mod 2=0) or (c mod 2=1) and (d mod 2=1) then
k:=1;
if t<>k then
writeln(NO)
else
writeln(YES);
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку