Для заданного числа N составьте программу вычисления суммы S=1/2-1/3+1/4-1/5+..+1/n, где n натуральное число.

///PascalABC.NET (версия 3.1, сборка 1198 от 11.03.2016)
var i,n: integer;
    s:real;
begin
  readln(n);
  s:=0;
  for i:=2 to n do  begin
  if i mod 2=0 then s:=s+1/i
     else s:=s-1/i ;
  end;
  writeln(s);
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку