Pascal только! Помогите! Даю 30 баллов
Напишите программу, которая вводит координаты двух точек на числовой оси и выводит расстояние между ними.
Входные данные
В первой строке вводятся через пробел координаты первой точки (сначала x -координата, потом y -координата), во второй строке в том же порядке – координаты второй точки. Все координаты – вещественные числа.
Выходные данные
Программа должна вывести одно число: расстояние между точками с тремя знаками в дробной части.
------------------------------------------------------------------------------------------------------------------------------
входные данные
1. 1.
2. 2.
выходные данные
1.414

Var x1,y1,x2,y2,d: real;
begin
  write(первая точка: x y);  readln(x1,y1); 
  write(вторая точка: x y);  readln(x2,y2);
 
  d:=sqrt(sqr(x2-x1)+sqr(y2-y1));
 
  writeln(расстояние:  ,d);
end.


Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку