Pascal!Даю 30 балов!!1!!!!
Написать программу,помогите
Дано 4-х значное число<вычислить произведение его чисел
Var a,a1,a2,a3,a4,p:integer;
begin
write(a = ); readln(a);
a1:=a div 1000;
a2:=a div 100 mod 10;
a3:=a div 10 mod 10;
a4:=a mod 10;
p:=a1*a2*a3*a4;
writeln(p = ,p);
end.
Пример:
a = 2345
p = 120
Оцени ответ
