1.В Древней Греции,говорят,была демократия. И все решали голосованием. По каждому вопросу гражданин ,например,Афин мог проголосовать "за","против" или не голосовать вообще.
Напишите программу,которая бы подсчитывала число голосов и выводила на экран сообщение о том, принято решение или отклонено.(Количество голосующих 10).
2.В массиве хранятся величины роста студентов(от 150 до 230 см).Определить,сколько человек смогут попасть в команду по баскетболу. Критерий отбора-минимальный рост 180 см.
Примечание:Массив заполняется случайными числами. В начале программы его необходимо вывести
Pascal
1){-1 - против; 0 - не голосовал; 1 - за. В приложении пример ввода}
var i,s,a:integer;
begin
for i:=1 to 10 do
begin
read(a);
s:=s+a;
end;
if s=0 then writeln(50/50) else
if s<0 then writeln(IIPOTUB) else writeln(3A);
end.
2){сначала вводим кол-во студентов}
uses crt;
var a:array[1..100] of integer;
k, i, s:integer;
begin
clrscr;
randomize;
read(k);
for i:=1 to k do
begin
a[i]:=random(150, 230);
write(a[i], );
end;
for i:=1 to k do
if a[i] >=180 then s:=s+1;
writeln(s);
end.
Оцени ответ
