Помогите пожалуйста! Написать блок-схему и программу для Паскаль!
Написать программу решения следующей задачи: Определить, является ли «счастливым» трамвайный билет с шестизначным номером («счастливым» считается билет, у которого сумма первых трёх чисел совпадает с суммой трёх последних чисел). Ответ вывести на печать.

Программа:
var n,a1,a2,s1,s2:integer;
begin
write(n = ); readln(n);
a1:=n div 1000;
s1:=(a1 div 100)+(a1 div 10 mod 10)+(a1 mod 10);
a2:=n mod 1000;
s2:=(a2 div 100)+(a2 div 10 mod 10)+(a2 mod 10);
if s1=s2 then writeln(Билет счастливый)
          else writeln(Билет не счастливый)
end.
Пример:
n = 123231
Билет счастливый

Блок-схема - в прилагаемом файле.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку