Человек откладывает Х рублей в месяц, эта сумма не постоянна и может менятся от 1000 до 150т.р, человек собирает 1,7м.р для покупки авто. Написать программу за сколько месяцев человек соберет сумму за авто
Var x,n,s:integer;
begin
Randomize;
n:=0;
s:=0;
while s<1700000 do
begin
n:=n+1;
x:=random(150001-1000)+1000;
s:=s+x;
end;
writeln(n = ,n);
end.
Пример:
n = 22
Оцени ответ
