Вася построил забор из имеющихся досок разной длины. Если рядом стоящие доски отличаются не более чем на 10 сантиметров, Вася считает эту часть забора ровной. Сколько есть неровных частей у забора? Формат ввода: n – количество досок в заборе (n <= 20) a1 – длина первой доски a2 – длина второй доски ... an – длина n-ой доски Пример ввода: 7 15 30 25 30 40 29 21 Формат вывода: kol - количество Пример вывода: 2 Пояснение: Неровных частей 2: (15,30) и (40,29).

//PascalABC.Net 3.1 сборка 1200
begin
    var a := ArrRandom(20, 10, 40);
    var n := 0;
    for var i := a.GetLowerBound(0) to a.GetUpperBound(0) - 1 do
        if abs(a[i] - a[i + 1]) >= 10 then begin
            n := n + 1;
            writeln(( + a[i] + , + a[i + 1] + ));
        end;
    writeln(n);
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку