Pascal 1. Дан прямоугольный треугольник с катетами a и b. Составьте программу для вычисления гипотенузы c, периметра, площади, радиуса вписанной и описанной окружности.
напишите программу в pascal

Program calculations;
var a,b,c, S, P,poluperimetr , Radius1, radius2: real;

begin
writeln (Enter a:);
readln(a);
writeln(Enter b:);
readln(b);
c:=sqrt(a*a+b*b);
S:=(a*b)/2;
P:=a+b+c;;
poluperimetr:=P/2;
Radius1:=c/2;
radius2:=sqrt(((poluperimetr-a)*(poluperimetr-b)*(poluperimetr-c))/poluperimetr);
writeln(c=,c:2:2);
writeln(S=,S:2:2);
writeln(P=,P:2:2);
writeln(Radius1=,Radius1:2:2);
writeln(radius2=,radius2:2:2);
readln;
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку