Напишите программу для решения следующей задачи.
На контрольной работе по алгебре ученикам 9 класса было предложено 10 примеров. Неудовлетворительная оценка выставляется, если правильно решено менее половины примеров. Сколько неудовлетворительных оценок было получено учениками? Если хотя бы один из учеников правильно решил все задачи, выведите YES, иначе выведите NO.
Программа получает на вход количество учеников в классе N (1 ≤ N ≤ 30), затем для каждого ученика вводится количество правильно решённых примеров.
(Pascal)
Входные данные 4
3
9
2
8
Выходные данные
2
NO

Var n,a,i,k:integer;
s:string;
begin
  s:=No; k:=0;
  readln(n);
  for i:=1 to n do begin
    readln(a);
    if a<5 then k:=k+1;
    if a=10 then s:=Yes;
  end;
  writeln(k);
  writeln(s);
end.


Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку