1.Составить программу вычисления суммы S=1+1/2+1/3+1/4+ | S= 1+1/2+1/3+1/4+1/n
2.Вычислите значения выражения (1+2) * (1+2+3) * (1+2+3+4) * (1+2+3+....10)
Решить в Pascal ABC.
1.
var i,n:integer; s:real;
begin
write(n = ); readln(n);
s:=0;
for i:=1 to n do s:=s+1/i;
writeln(s = ,s);
end.
Пример:
n = 5
s = 2.28333333333333
2.
var x,a,s:real; i:integer;
begin
write(x = ); readln(x);
a:=x; s:=x; i:=1;
while i<11 do
begin
i:=i+2;
a:=x*x*a;
s:=a/i;
end;
writeln(s = ,s);
end.
Результат:
x = 3
s = 16104.2727272727
Оцени ответ
