C++Напишите программу, которая заполняет массив из N элементов членами арифметической прогрессии с начальным значением X и разностью D .
Входная строка содержит три целых числа: начальное значение X , разность D и размер массива N , разделённые пробелом. Гарантируется, что 0 < N ≤ 10000 .
Программа должна вывести содержимое массива: N первых членов арифметической прогрессии с начальным значением X и разностью D .
входные данные
8 4 5
выходные данные
8 12 16 20 24

#include
using namespace std;
int main()
{
setlocale (0,"");
string mas [20];
int x;
int n;
int d;
cout<<"введите начальное число x: ";
cin >> x;
cout<<"введите число членов массива n: ";
cin >> n;
cout<<"введите разность чисел d: ";
cin >> d;
for (n;n>=1; n--)
{
cout< x=x+d;
}
return 0;
}

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку