Во время пересадки леса работники посадили лес в зависимости от кол-во саженцев . саженцев ореха хватило на первые сто метров, саженцев яблони ещё на сто метров, саженцев дуба хватило ещё на сто метров. Напишите программу которая выводит на печать название леса в зависимости от кол-во метров( пример 1..10:writeln(‘oreh’);).

Var
a :integer;
begin
repeat
writeln(Сколько метров?);
readln(a);
if a <= 100 then
 begin
   if a < 0 then writeln(Там нет леса!) else writeln(Там посажен орех.);
 end;
if a > 100 then
 begin
   if a <= 200 then writeln(Здесь посажена яблоня);
 end;
if a > 200 then
 begin
 if a <= 300 then writeln(Здесь посажен дуб.);
 if a > 300 then writeln(Здесь нет леса);
 end;
until a = 99999;
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку