Дано N пар чисел Xi, Yi. Подсчитайте количество таких пар, что Xi^2 + Yi^3 принадлежит диапазону от L до R включительно.
Примечание:
Здесь ^ - это операция возведения в степень. То есть,
Xi^2 = Xi*Xi
Yi^3 = Yi*Yi*Yi
Формат ввода:
n – количество пар чисел (n <= 12)
L R - левая и правая границы диапазона
X1 Y1 – первая пара чисел
X2 Y2 - вторая пара чисел
...
Xn Yn – n-ая пара чисел
Пример ввода:
3
5 30
1 1
2 1
1 3
Формат вывода:
k - количество пар чисел
Пример вывода:
2
// PascalABC.NET 3.1, сборка 1201 от 18.03.2016
begin
var n:=ReadInteger;
var L,R,x,y:integer;
Read(L,R);
var k:=0;
for var i:=1 to n do begin
Read(x,y);
if x*x+y*y*y in [L..R] then Inc(k)
end;
Writeln(k)
end.
Тестовое решение:
3
5 30
1 1
2 1
1 3
2
Оцени ответ
