Дан двумерный массив. Проверить, есть ли в нем одинаковые элементы. Помогите, пожалуйста, написать программу в паскале

Program arr;
Const n=3;
var i, j, tmp, k, z:integer;
    c:boolean;
    a:array [1..n,1..n] of integer;

begin
c:=false;
for i:=1 to n do
  for j:=1 to n do
    read(a[i][j]);
for i:=1 to n do
  for j:=1 to n do
    begin
    tmp:=a[i][j];
    for k:=i+1 to n do
      for z:=j+1 to n do
        if tmp = a[k][z] then
        c:=true;
    end;
writeln;
for i:=1 to n do
begin
  for j:=1 to n do
    write(a[i][j], );
  writeln;
end;
if c = true then
  writeln(В данном массиве есть равные друг другу элементы)
  else writeln(Элементы, равные друг другу, отсутсвуют в данном массиве);
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку