‭Помогите пожалуйста написать программу на Паскаль. Производительность станка для резки бетона мозаичных плит составляет А см^2/ч. После того, как на станке нарезали плиты общей площадью В см^2, станок останавливают на Т1 мин, после чего вновь нарезают В см^2 плит с последующим перерывом на Т1 мин и т.д. Вычислите значение площади нарезанных плит S см^2 за общее время работы Т2 часов.

Программа:
var a,b,t1,t2:integer; t,s:real;
begin
write(A = ); readln(a);
write(B = ); readln(b);
write(T1 = ); readln(t1);
write(T2 = ); readln(t2);
t:=(b/a*60+t1);
s:=t2*60/t*b;
writeln(S = ,s);
end.

Пример:
A = 600
B = 300
T1 = 10
T2 = 5
S = 2250

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку