Господа программисты и те кто хорошо шарит в Pascalе , помогите мне с задачами. Нужно решение срочно!
1.Составить наиболее краткий алгоритм вычисления на Pascal.
y=x^5
y=x^10
y=x^15
y=x^19
2. Составить алгоритм тройного обмена значениями переменных по схеме(на фотографии по номером 2)

1. 
1)
var x,y:real;
begin
readln(x);
y:=x*x;
y:=y*y*x;
writeln(x^5=,y);
end.
2)
var x,y:real;
begin
readln(x);
y:=x*x;
y:=y*y*x;
y:=y*y;
writeln(x^10=,y);
end.
3)
var x,y:real;
begin
readln(x);
y:=x*x;
y:=y*y*x;
y:=y*y*y;
writeln(x^15=,y);
end.
4)
var x,y:real;
begin
readln(x);
y:=x*x;
y:=y*y*y*y*x;
y:=y*y*x;
writeln(x^19=,y);
end.
2.
var a,b,c,z,t:real;
begin
readln(a,b,c);
z:=a;
t:=b;
a:=c;
b:=z;
c:=t;
writeln(a=,a,b=,b,c=,c);
end.




Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку
×