Написать программу с использованием цикла с постусловием рараметром и составит и блок схемы дано натуральное число определить количество его нечетеых делителей
Program dividers;
var
c,i,n :Integer;
begin
readln(n);
repeat
if ( (n mod i) = 0 ) and ( (i mod 2) <> 0) then c:= c + 1;
if ( (n / i) mod 2) <> 0 then c:= c + 1;
i:= i + 1;
until i < (sqrt(n) + 1);
writeln(c);
end.
Оцени ответ
