Алгоритм вычисления значений функций F(n) и G(n), где n – натуральное число, задан следующими соотношениями:
F(1) = 1; G(1) = 1;
F(n) = 2*F(n–1) – G(n–1),
G(n) = 2*F(n–1) + G(n–1), при n >=2
Чему равно значение величины F(5)-G(5)? В ответе запишите только целое число.
F1 = 1
G1 = 1
F2 = 2*1 - 1 = 1
G2 = 2*1 + 1 = 3
F3 = 2*1 - 3 = -1
G3 = 2*1 + 3 = 5
F4 = 2*(-1) - 5 = -7
G4 = 2*(-1) + 5 = 3
F5 = 2*(-7) - 3 = -17
G5 = 2*(-7) + 3 = -11
-17 + 11 = -6
function g(n:integer):integer; forward;
function f(n:integer):integer;
begin
if n = 1 then f := 1
else
f := 2*f(n-1) - g(n-1)
end;
function g(n:integer):integer;
begin
if n = 1 then g := 1
else
g := 2*f(n-1) + g(n-1)
end;
begin
write(f(5) - g(5))
end.
Оцени ответ
