Ряд чисел Фибоначчи задается следующим образом: первые два числа равны 1 ( F 1 = F 2 = 1 ), а каждое следующее равно сумму двух предыдущих: F i = F i-1 + F i-2. Напишите программу, которая вводит натуральное число N и заполняет массив из N элементов первыми N числами Фибоначчи.
Входные данные
Входная строка содержит размер массива N . Гарантируется, что 0 < N ≤ 40 .
Выходные данные
Программа должна вывести содержимое массива: первые N чисел Фибоначчи. Программа - PYTHON !!!!!!!! Только PYTHON.

def fib(n):
    if n == 0:
        return 0
    if n == 1 or n == 2:
        return 1
    return fib(n-1)+fib(n-2)

n = int(input(Input N ))
a = [0]*n
for i in range(1,n+1):
    a[i-1] = fib(i)
    print(a[i-1])

Тестовое решение:
Input N 10
1
1
2
3
5
8
13
21
34
55

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку