Написать программу,которая определяет количество всех чисел из диапазона от 5 до 25.(Паскаль)
Входные данные:1,6,35,12,18,24,0.

Program Summa;

Uses Crt;

var s,n,c:integer;

 

 begin

   clrscr;

   write(Введите числа коннц ввода 0: );

    s:=0;c:=0; 

    repeat

        readln(n);

        c:=c+1; 

if (n mod 2)=0 then
      if ((n>=5)and (n<=25)) then s:=s+n;        

  until (n=0) or (c=1000) ;    

write(Сумма ,c, чётных чисел в диапазоне от 5 до 25:,s);

   readkey;

 

end. 
:D

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку