Даны две дроби a/b и c/d где a,b,c,d натуральные числа.Требуется найти их сумму и записать в виде x y/z(или y/x,если x=0), где y/z-несократимая дробь. Составьте программу для решения этой задачи.
Var a,b,c,d,x,y,z,y1,z1,y2,z2,nod:integer;
begin
writeln(1-я дробь (числитель и знаменатель):);
readln(a,b);
writeln(2-я дробь (числитель и знаменатель):);
readln(c,d);
y1:=a*d+c*b; y2:=y1;
z1:=b*d; z2:=z1;
while (y2>0)and(z2>0) do
if y2>z2 then y2:=y2 mod z2 else z2:=z2 mod y2;
nod:=y2+z2;
y1:=y1 div nod;
z:=z1 div nod;
x:=y1 div z;
y:=y1 mod z;
if x>0 then writeln(x, ,y,/,z) else writeln(y,/,z);
end.
Пример:
1-я дробь (числитель и знаменатель):
1 10
2-я дробь (числитель и знаменатель):
2 5
1/2
Оцени ответ
