Дан прямоугольник, длины сторон которого a и b являются натуральными числами.Определить, на сколько квадратов максимальной площади можно разделить данный прямоугольник,укажите их размеры.Составьте программу на паскале абс

Var a,b,c,d,nod,k:integer;
begin
write(a = ); readln(a);
write(b = ); readln(b);
c:=a; d:=b;
while (c>0)and(d>0) do
 if c>d then c:=c mod d else d:=d mod c;
nod:=c+d;
k:=(a div nod)*(b div nod);
writeln(k, квадратов размером ,nod,x,nod);
end.

Пример:
a = 6
b = 15
10 квадратов размером 3x3

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку