Написать программу,в которой осуществляется ввод целых чисел(ввод осуществляется до тех пор пока не будет введён ноль)и подсчёт суммы и среднего
арифметических введённых положительных чисел.используйте оператор repeat.
Var n,k,s:integer;
begin
repeat
readln(n);
if n>0 then begin
s:=s+n;
k:=k+1;
end;
until n = 0;
writeln(Сумма: ,s);
writeln(Сред.ариф: ,s div k);
end.
Оцени ответ
