Напишите программу, которая в последовательность целых чисел определяет произведение первого числа и всех положительный чисел
Program pr;
uses crt;
Var a,k,k1:integer;
Begin
Writeln(Введите a);
readln(a);
k1:=1;
k:=0;
While (a<>0) and (k1<1000) do
Begin
if (a<0) and (a mod 2=0) and (abs(a)<=30000) then k:=k+1;
k1:=k1+1;
readln(a);
end;
Writeln(k=,k);
readln;
end.
Оцени ответ
