
Написать программу на Паскале для решения следующей задачи: Дан массив из 20 элементов. Необходимо посчитать количество пар элементов, в которых есть хотя бы 1 нечетный элемент. Под парой элементов считать 2 рядом стоящих элемента.

// PascalABC.NET 3.1, сборка 1204 от 24.03.2016
begin
var a:=ArrRandom(ReadInteger(n=),-30,30);
a.Println;
var b:=a.Pairwise.Where(i->(i.Item1.IsOdd) or
(i.Item2.IsOdd)).Count;
Writeln(Количество пар= ,b)
end.
Тестовое решение:
n= 15
-5 7 12 -11 29 11 -28 19 20 28 -6 30 26 -14 27
Количество пар= 9
Оцени ответ