Напишите программу которая считает произведение цифр введенного натурального числа..помогите пожалуйста!
Var
n, p: integer;
begin
write(Число: );
readln(n);
p := 1;
while n > 0 do
begin
p := p * (n mod 10);
n := n div 10
end;
writeln(Произведение цифр = , p);
end.
Тест №1
Число: 54321
Произведение цифр = 120
Тест №2
Число: 54320
Произведение цифр = 0
Оцени ответ
