Нужно составить программу,содержащую ветвления и определяющую,принадлежит ли точка с координатами (x,y) заштрихованной области.

Var x,y:real;
begin
  readln (x,y);
  if ((x>0) and (y>0))or((sqr(x)+sqr(y))>36)  then writeln(Точка не принадлежит фигуре) else
  if (sqr(x)+sqr(y))<=36 then writeln (Точка принадлежит фигуре);
end.

Тест №1
2 3
Точка не принадлежит фигуре

Тест №2
-1 3
Точка ринадлежит фигуре

Тест №3
-3 -8
Точка не принадлежит фигуре





Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку