Напишите алгоритм в виде программы на Паскале
__________________________________________
Напишите АЯ алгоритм вычисления у по формуле
у=(1-х²+5х^4)², где х- заданное число. Учтите следующие ограничения: 1) в арифмитических выражения можно использовать только операции сложения, вычитания и умножения. 2) Каждое выражение может содержать только одну арифметическую операцию. Выполните трассировку алгоритма при х= 2.
__________________________________________
Добавлю баллы за ответ без ошибок!!!!!!

Var x,x2,x4,y:real;
begin
write(x = ); readln(x);
x2:=x*x;
x4:=x2*x2;
x4:=5*x4;
y:=1-x2;
y:=y+x4;
y:=y*y;
writeln(y = ,y);
end.

Пример:
x = 2
y = 5929

Трассировка:
x=2
x2=2*2=4
x4=4*4=16
x4=5*16=80
y=1-4=-3
y=-3+80=77
y=77*77=5929

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку
×