Составить программу для решения задачи:
Дана строка. Проверить правильность написания слов с ЖИ-ШИ. Если слово написано неправильно,то исправить его.

Var a:string;
i:longint;

begin
readln(a);
for i := 2 to length(a) do
begin
if (a[i] = ы) then
if (a[i-1] = ж) or (a[i-1] = ш) then a[i] := и;
end;

writeln(a);
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку
×