Написать программу, которая проверяет, представляют ли элементы введенного с клавиатуры массива возрастающую последовательность
PascalABC:
var a:array of real;
k,i,n:integer;
x:real;
begin
write(Задайте размер массива = );readln(n);
setlength(a,n);
for i:=0 to n-1 do begin
readln(a[i]);
if (i>0) and (k=0) and (x>a[i]) then k:=1;
x:=a[i];
end;
if k=1 then writeln(Элементы массива не являются возрастающей последовательностью)
else writeln(Элементы массива являются возрастающей последовательностью);
end.
Оцени ответ
