Написать программу в которой вводятся целые числа и подсчёт количества введённых положительных и отрицательных чисел

Не указано сколько раз оно должно принимать значение и каким образом вообще принять. Здесь оно 5 раз примет какие-то числа (каждое с новой строки), а потом выведет кол-во + и -. Значение 0 оно просто пропускает. Если все 5 чисел будут = 0, то и на выходе оно скажет, что было введено 0 значений с + и 0 значений с-.

Код (скриншот прилагается):
var minus, plus, input, i: integer;
begin
minus:= 0;
plus:= 0;
for i:=0 to 4 do
begin
readln(input);
if input > 0 then plus:=plus+1;
else if input < 0 then minus:=minus+1;
end;
writeln(plus,  positive and , minus,  negative numbers.);
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку