Var A:array [1...5] of integer
g,j:byte;
Begin
randomize;
for j:=1 to 5 do
begin
A[j]:= random(9);
writeln(A[j]);
end;
for j:=1 to 5 do
begin
for g:=5 down to j do
begin
if A[g-1] begin
K:=A[j-1];
A[g-1]:=A[g];
A[g]:=K;
for l:=1 to 5;
end;
for j:=1 to 5 do
write(A[j])
and;and;End.
Проверьте на ошибки, и как составить программу Найдите наибольшее и наименьшее в однородном массиве.

Очень много ошибок. Уже в 1 строке программы 2 ошибки: три точки вместо двух и отсутствует точка с запятой в конце строки. Ну и так далее.
Рабочий код из вашего может быть таким:

var
  A: array [1..5] of integer;
  g, j, k, l: byte;
begin
  randomize;
  for j := 1 to 5 do
  begin
    A[j] := random(9);
    writeln(A[j]);
  end;
 
  for j := 1 to 5-1 do
  begin
    for g := j+1 to 5 do
    begin
      if A[j] > A[g] then begin
        K := A[j];
        A[j] := A[g];
        A[g] := K;
      end;
    end;
  end; 
  for j := 1 to 5 do
    write(A[j]);
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку