Написать программу на паскале: найти разность между К и суммой всех элементов массива с нечетными индексами

Желательно в задании уточнять тип массива (целый, вещественный ) и споособ его генерации(ввод с клавиатуры, генератор случайных чисел).

 

В данной программе массив получен с помощью  генератора случайных чисел 

 

  

Program raznost;

Uses Crt;

const n=100; {максимальный размер массива}

var a:array[1..n] of  integer; 

 

       i,m:integer;

       k,s,rez:longint;

begin

     clrscr;

     write(Введите К: );

     readln(k);

     write(Введите размер массива <100: );

     readln(m);

 

 

     randomize; 

     write(Исходный массив:)

 

    s:=0;

     for i:=1 to m do

          begin

               a[i]:=random(50)+25;   

 

               write(i:3);   

 

               if  (i mod 2)<>0 then s:=s+a[i];

 

           end;

     writeln;

     rez:=k-s;       

     writeln(Разность между K и суммой всех элементов массива с нечетными индексами=,rez);

     readkey;

end. 

 

 

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку