Помогите пожалуйста !!!!Написать программу на языке Pascal решения квадратного уравнения. Программа должна проверять правильность введенных пользователем данных и в случае, если коэффициент при второй степени неизвестного равен нулю, выводить соответствующее сообщение.

var a,b,c,d:integer; x1,x2:real;
begin
writeln(Введите коэффициенты);
readln(a,b,c);
d:=b*b-4*a*c;
if (d<0) then writeln(Нет решения)
else if (d=0) then
begin
x1:=-b/(2*a);
writeln(x=,x1);
end
else begin
x1:=(-b+sqrt(d))/(2*a);
x2:=(-b-sqrt(d))/(2*a);
writeln(x1= ,x1,x2=,x2);
end;

readln
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку