Напишите программу, которая заменяет в символьной строке все буквы a на буквы b , буквы A на буквы B , буквы b на буквы a и буквы B на буквы A .
в c++

#include
#include
using namespace std;

int main()
{
string st;
cout <<"Введите строку; ";
getline(cin, st);
for(auto it=st.begin(); it!=st.end(); ++it)
{
switch(*it)
{
case a: { *it=b; break; }
case b: { *it=a; break; }
case A: { *it=B; break; }
case B: { *it=A; break; }
}

}
cout <<"Измененная строка: " <
return 0;

}

Результат работы программы на скриншоте.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку