Дано трёхзначное число. Напишите программу, которая определяет: есть ли среди цифр заданного целого трёхзначного числа одинаковые;

var

  a : integer;

begin

  write (A = );

  readln (a);

  if (a > 999) or (a < 100) then

    writeln (Число не трехзначное)

  else if (a mod 10 = a div 100) or (a mod 10 = a mod 100 div 10) or

              (a div 100  = a mod 100 div  10) then

    writeln (Да, есть)

  else

    writeln (Нет, нету);

  readln;

end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку