Рабочему нужно изготовить 330 деталей Первые 7 дней он изготавливал 10 деталей в день, следующие 7 дней на 5 деталей в день больше, следующие 7 ещё на 5 деталей больше и т.д. Сколько дней нужно рабочему, чтобы изготовить нужное количество деталей?
Составьте программу в паскале,прошу
Var col,day,day_w,col_w:integer;
begin
day:=7;
col_w:=10;
col:=0;
while (col<=330) do begin
col:=col+col_w;
day_w:=day_w+1;
writeln(col);
if day_w mod 7 = 0 then col_w:=col_w+5;
end;
writeln(рабочий изготавливал 330 деталей за ,day_w, дней);
end.
Оцени ответ
