Уровень A. На вход программы подаются данные о результатах районной олимпиады. В первой строке – количество участников N, а следующие N строк имеют следующий формат:
<Фамилия> <Имя> <Баллы>
Здесь <Фамилия> – строка, состоящая не более чем из 20 символов; <Имя> – строка, состоя-щая не более чем из 15 символов; <Баллы> – целое число, обозначающее общее количество баллов, набранное участником. Все данные разделены пробелами. Пример входной строки:
Петечкин Вася 152
Чтобы на городскую олимпиаду проходят участники, набравшие в сумме более 100 баллов. Требуется вывести количество участников, прошедших на городскую олимпиаду.
//Pascal ABC.NET v3.1 сборка 1172
type
re=record
sub:string;
name:string;
co:integer;
end;
Var
n,i,k:integer;
ar:array of re;
begin
readln(n);
setlength(ar,n+1);
for i:=1 to n do
begin
writeln(Введите фамилию участника №,i);
readln(ar[i].sub);
writeln(Введите имя участника №,i);
readln(ar[i].name);
writeln(Введите баллы участника №,i);
readln(ar[i].co);
if ar[i].co>100 then inc(k);
end;
writeln(Количество прошедших=,k);
end.
Пример ввода:
4
Введите фамилию участника №1
Двачевская
Введите имя участника №1
Алиса
Введите баллы участника №1
99
Введите фамилию участника №2
Персунов
Введите имя участника №2
Семён
Введите баллы участника №2
101
Введите фамилию участника №3
Коллайдер
Введите имя участника №3
Виола
Введите баллы участника №3
999
Введите фамилию участника №4
Сиина
Введите имя участника №4
Микадо
Введите баллы участника №4
100
Пример вывода:
Количество прошедших=2
