Составьте программу на языке Паскаль для решения квадратного уравнения.Коэффициенты a,b и c вводятся с клавиатуры.На экране выводится информация о
значении корней квадратного уравнения.

Var
a,b,c,x1,x2,d:real;
begin
write(Введите A=); readln(a);
write(Введите B=); readln(b);
write(Введите C=); readln(c);
D:=b*b-4*a*c;
if D<0 then begin
writeln(Нет корней);
end;
if D=0 then begin
writeln(x1=,-b/(2*a))
end;
if D>0 then begin
x1:=(-b-sqrt(d))/(2*a);
x2:=(-b+sqrt(d))/(2*a);
writeln(x1=,x1);
writeln(x2=,x2);
end;
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку