Помогите составить программу
1. нужна программа на тему Алгоритма Евклида, составьте пожалуйста,чтобы в паскаль её забить.
Программа для нахождения наибольшего общего делителя.

//Pascal ABC.NET v3.1 сборка 1172

var
  a, b, nod: integer;

begin
  read(a, b);
  while a * b <> 0 do
    if a > b then a := a mod b
    else b := b mod a;
  nod := a + b;
  writeln(nod);
end.

Пример ввода:
1071
462
Пример вывода:
21


Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку