Написать программу для паскаля:
Массив А, состоящий из 10 целых элементов задан через random. Все элементы массива разделить на 2 элемент. Вывести на экран старый и новый массив.
//Pascal ABC.NET v3.1 сборка 1172
Const
n=10;
Var
ar:array[1..n] of real;
i:integer;
k:real;
begin
randomize;
writeln(First array:);
for i:=1 to n do
begin
ar[i]:=random(100);
write(ar[i]:4);
end;
k:=ar[2];
for i:=1 to n do
ar[i]:=ar[i]/k;
writeln;
writeln(Final array:);
for i:=1 to n do
writeln(ar[i]);
end.
Оцени ответ
