1)Присвоить переменным a,b,c значения 10,20,30.
2)Что является результатом выполнения оператора:
Write(a)
Write(a)
Write(a=,a)
3)Каким образом можно вывести на экран число в формате с фиксированной запятой?
4)Дан фрагмент команды a:=10 b:=a+1 a:=b-a write(a,b) Какие числа будут выведены на экран компьютера?
5)Напишите программу которая вычисляет площадь и периметр прямоугольника по двум его сторонам.

1.
a:=10;
b:=20;
c:=30;
2.
При write(a) - выведется на экран просто значение а;
При write(a) - выведется просто буква "а";
При write(a=, a) - выведется на экран, например: a=10
3. Чтобы вывести на экран число с фиксированной запятой нужно написать write(a:0:3). a - должна быть вещественного типа. 3 - означает три знака после запятой, поэтому если у вас число 1.2758234, то будет выведено на экран 1.275

4. 
a = 1;
b = 11;

5.

program pl;
var 
a, b : integer;
s, p : real;
begin
writeln("Введите первую сторону прямоугольника:");
readln(a);
writeln("Введите вторую сторону прямоугольника:");
readln(b);
p = 2*(a+b);
s = a*b;
writeln("Площадь прямоугольника равна:", s);
writeln("Периметр прямоугольника равен:", p);
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку