Написать программу которая в последовательности целых чисел определять значение наименьшего числа из всех чисел.Программа получает на вход целые положительные, числа количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 - признак окончания ввода не входит в числовую последовательность). Количество целых чисел не превышает 1000. Все числа не превосходят 30000 . Программа должна вывести: наименьшее число из всех чисел.

На C++:

#include
using namespace std;

int main()
{
int count=1, min=30001, val;
do
{
cin >>val;
if(val>30000) val-=30000;
if((val0)) min=val;
if(count<1000) ++count;
} while(val>0);

cout <<"Минимальный элемент: " <
return 0;
}

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку