Реализовать процедуру или функцию, реализующую следующие операции над одномерными массивами. Написать программу, использующую данные алгоритмы.
!Работу пррограммы организовать в виде функций! -Язык Программирования(Pascal)
1. Заменить положительные элементы массива единицами, отрицательные – нулями, посчитать количество положительных и отрицательных элементов. * Сделать в старом формате FPC.

{ Free Pascal }

procedure Println(a:array of integer);
var
  i:integer;
begin
  for i:=0 to Length(a)-1 do Write(a[i], );
  Writeln
end;

procedure Ex1(var a:array of integer; var nn,np:integer);
var
  i:integer;
begin
  nn:=0; np:=0;
  for i:=0 to Length(a)-1 do
    if a[i]<0 then begin a[i]:=0; Inc(nn) end
    else
      if a[i]>0 then begin a[i]:=1; Inc(np) end
end;

var
  a:array of integer;
  i,n,kp,kn:integer;
begin
  Randomize;
  Write(Количество элементов: ); Read(n);
  SetLength(a,n);
  for i:=0 to n-1 do a[i]:=Random(41)-20;
  Println(a);
  Ex1(a,kn,kp);
  Writeln(Отрицательных ,kn,, положительных ,kp);
  Println(a)
end.

Во вложении - пример работы программы.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку