Составить программу паскаль, которая выводит на экран олимпийские кольца.
Срочно, заранее большое спасибо)

Uses crt,graph;
var
  gd, gm, xc, yc, r, x, y: integer;

begin
  clrscr;
  repeat
    writeln(Vvedite koordinaty levogo kolca, x=[50..300], y=[50..350]:);
    readln(xc, yc);
  until((xc >= 50) and (xc <= 300)) and ((yc >= 50) and (yc <= 350));
 
  gd := 0;
  initgraph(gd, gm, );
  setbkcolor(15);
  cleardevice;
 
  r := 50;
  setlinestyle(0, 0, 3);
  setcolor(9);
  circle(xc, yc, r);
  setcolor(8);{темно-серый, черный не нарисовать}
  circle(xc + 2 * r, yc, r);
  setcolor(12);
  circle(xc + 4 * r, yc, r);
  setcolor(14);
  circle(xc + r, yc + r, r);
  setcolor(10);
  circle(xc + 3 * r, yc + r, r);
  readln
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку