Напишите программу, которая в последовательности целых чисел определяет их количество и подсчитывает сумму положительных чётных чисел, не превосходящих 256. Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа по модулю не превышают 30 000. Программа должна вывести два числа: длину последовательности и сумму положительных чётных чисел, не превосходящих 256.
var a, b, c: integer;
begin
b:=0;
c:=0;
while a<>0 do
begin
readln(a);
b:=b+1;
if (a<=256) and (a mod 2=0) then c:=c+a;
readln(a);
end;
writeln(dlina=,b, cymma=,c)
end.
Оцени ответ
