Помогите написать программу на паскале, используя циклы!!!
Найти количество различных цифр данного натурального числа.
//Pascal ABC.NET v3.1 сборка 1172
Var
k:integer;
se:set of char;
s:string;
num:set of 0..9;
begin
readln(s);
num:=[0..9];
while s<> do
begin
if (not(s[length(s)] in se)) and (s[length(s)] in num) then
begin
inc(k);
se:=se+[s[length(s)]];
end;
delete(s,length(s),1);
end;
writeln(k);
end.
Пример ввода:
234Мне нужно делать историю, что я тут забыл?121
Пример вывода:
4
Оцени ответ
