Написать программу, которая принимает от пользователя количество числовых значений (указывает сам пользователь) для переменной и считает количество введенных трехзначных чисел, если учитывать, что вводиться могут числа в диапазоне от 0 до 10000 (по умолчанию).
//PascalABC.NET (версия 3.1, сборка 1210 от 29.03.2016)
var a,i,n,n3:integer;
begin
writeln(Введите количество чисел);readln(n);
for i:=1 to n do begin
readln(a);
if (a>99) and (a<1000) then n3:=n3+1;
end;
writeln(Всего трехзначных чисел :,n3);
end.
Тестовое решение:
Введите количество чисел
5
22
123
4
435
12
Всего трехзначных чисел :2
Оцени ответ
